WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33474 closed defect (bug) (invalid)

Data base and PHP

Reported by: humoba Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Database Keywords:
Focuses: performance Cc:

Description

After uptade to Wordpress 4.3 i have many problems with the database (MariaDB) and with PHP.

With MariaDB aks me for more resources:

150820 16:37:49 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
150820 16:37:49 [Warning] Could not increase number of max_open_files to more than 1024 (request: 8703)
150820 16:37:49 InnoDB: The InnoDB memory heap is disabled
150820 16:37:49 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150820 16:37:49 InnoDB: Compressed tables use zlib 1.2.7
150820 16:37:49 InnoDB: Using Linux native AIO
150820 16:37:49 InnoDB: Initializing buffer pool, size = 512.0M
150820 16:37:49 InnoDB: Completed initialization of buffer pool
150820 16:37:49 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
150820 16:37:49  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
150820 16:37:49  InnoDB: Waiting for the background threads to start
150820 16:37:50 Percona XtraDB (http://www.percona.com) 5.5.40-MariaDB-36.1 started; log sequence number 9672045152
150820 16:37:51 [Note] Plugin 'FEEDBACK' is disabled.
150820 16:37:51 [ERROR] mysqld: File '/var/lib/mysqllogs/slow-log' not found (Errcode: 13)
150820 16:37:51 [ERROR] Could not use /var/lib/mysqllogs/slow-log for logging (error 13). Turning logging off for the whole duration of the MySQL server process. To turn it on again: fix the cause, shutdown the MySQL server and restart it.
150820 16:37:51 [Note] Server socket created on IP: '0.0.0.0'.
150820 16:37:51 [Warning] 'proxies_priv' entry '@ root@node-02' ignored in --skip-name-resolve mode.
150820 16:37:51 [Note] Event Scheduler: Loaded 0 events
150820 16:37:51 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.5.41-MariaDB-log'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MariaDB Server

In PHP the memory isn't sufficient, ask me for more memory too

[:error] [pid 32523] [client 189.201.176.57:62738] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 6387425 bytes) in /home/www/vhosts/site.com/httpdocs/wp-includes/wp-db.php on line 1094, referer: https://site.com

After update, everything it was good.

Change History (1)

#1 @pento
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.3 deleted

Thanks for contacting us, @humoba!

The MariaDB log indicates that it crashed at some point, but it recovered immediately.

As for the PHP memory error, it occurred in a call to WPDB, but it could've come from anywhere - somewhere else in WordPress, or from a plugin or theme.

If you run into any other problems, I recommend posting on the Support Forums - they'll be able to help distill the problem down to find out if it's a WordPress bug or not.

Note: See TracTickets for help on using tickets.