WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#33727 closed enhancement (duplicate)

jQuery UI Datepicker has no core styling

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Administration Keywords:
Focuses: ui Cc:
PR Number:

Description

It's possible for plugins to enqueue the jQuery UI Datepicker widget, but doing so does not include any styling, and there is no recommended styling with it to match the color schemes in WordPress's administration area.

This is good in that developers can roll their own to match their needs, but it's bad in that there is no canonical recommended experience for end-users of those plugins.

Right now, the only real viable option is using the kinda-outdated jQuery UI styling generator as a starting off point, and working backwards from there. Even though WordPress core doesn't currently use the jQuery UI Datepicker internally, it might go a long way towards improving date & time experiences (I'm looking at you, post publish time.)

Change History (4)

#1 @johnjamesjacoby
4 years ago

I've put together a base CSS file on Github, for consideration, iteration, and ideally core adoption someday. This way any interested parties can collaborate outside of Trac while we see how viable this is for core, and can come back here and report back any progress.

https://github.com/stuttter/wp-datepicker-styling

#2 @jdgrimes
4 years ago

Related: #29420, #7665, #18909

I think it is a duplicate of #18909.

#3 @jadpm
3 years ago

I would also like to point out that lacking a common style for the builtin datepicker script means that each plugin using it adds its won, which causes several conflicts and overrides.

I strongly hope to see this landing soon.

#4 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18909.

Note: See TracTickets for help on using tickets.