WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33846 closed defect (bug) (invalid)

LastPass fix disturbs input from keyboard to password box.

Reported by: bulblub Owned by: adamsilverstein
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: General Keywords:
Focuses: javascript Cc:

Description

$pass2 = $('#pass2').on( inputEvent, function () {
	if ( $pass2.val().length > 0 ) {
		$pass1.val( $pass2.val() );
		$pass2.val('');
		currentPass = '';
		$pass1.trigger( 'pwupdate' );
	}
} );

Restrict if #pass2 field is hidden

$pass2 = $('#pass2').on( inputEvent, function () {
	if ( $pass2.val().length > 0 && $pass2.is(':hidden') ) {
		$pass1.val( $pass2.val() );
		$pass2.val('');
		currentPass = '';
		$pass1.trigger( 'pwupdate' );
	}
} );

Attachments (1)

test.gif (88.5 KB) - added by bulblub 6 years ago.
"パスワード" means Password in Japanese.

Download all attachments as: .zip

Change History (3)

@bulblub
6 years ago

"パスワード" means Password in Japanese.

#1 @adamsilverstein
6 years ago

  • Owner set to adamsilverstein
  • Status changed from new to assigned

@bulblub:

Thanks for the bug report. The pass2 field should be HIDDEN on your screen. I'm not sure why you are seeing the second, hidden field.

Can you please test this with only the default theme and plugins active?

If so, I will dig further to see if there is an issue with the Japanese release.

#2 @adamsilverstein
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

I went ahead and downloaded and installed the current WordPress Japanese release and was unable to reproduce the issue you mentioned.

@bulblub I think you are seeing a conflict with your theme or a plugin you have active. I would suggest disabling plugins, and switching to the default theme to see where the problem is, I don't think it is in WordPress core.

Here is a screencast of the password reset form on the user profile page, in the Japanese version:

http://cl.ly/image/1A1h2M1h3L0M/Screen%20Recording%202015-10-02%20at%2004.22%20PM.gif

Note: See TracTickets for help on using tickets.