WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#34054 closed defect (bug) (fixed)

Search for IPv6 addresses in comments not working

Reported by: nielsvanrenselaar Owned by: dd32
Milestone: 4.4 Priority: normal
Severity: normal Version:
Component: Comments Keywords:
Focuses: administration Cc:

Description

We've enabled IPv6 support for a couple of high traffic sites. We are now receiving a widespread of comments with IPv6 addresses. It seems that in the admin the IPv6 addresses are clickable, but don't contain a link like a normal IPv4 address. It should be possible to search for IPv6 addresses too.

I suspect it has to do with add_query_arg in wp-admin/includes/class-wp-comments-list-table.php.php line 651 which doesn't support the structure of a IPv6 address.

Change History (5)

#1 @DrewAPicture
5 years ago

  • Component changed from Administration to Comments

#2 @swissspidy
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The problem is not in add_query_arg, but in esc_url. See #34202

#4 @dd32
5 years ago

  • Milestone set to 4.4
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version trunk deleted

#5 @dd32
5 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from reopened to closed

In 35368:

Comments: Use a full URL rather than a relative one for links which can contain IPv6 addresses to avoid an issue where the URL was being eaten by escaping functions.

See #34407, #34202
Fixes #34054

Note: See TracTickets for help on using tickets.