WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#34520 closed defect (bug) (duplicate)

nbsp converts to hidden no break space when swapping text mode visual.

Reported by: BackuPs Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Editor Keywords:
Focuses: Cc:

Description

I found a weird behaviour regarding no break spaces.

If you are in text mode and add

<p>&nbsp;</p>

and swap to visual mode and back to text mode. the nbsp; stays visible as code

but if you add

Hello&nbsp;world

swap to visual mode and back the nbsp is converted to a hidden nbsp space. Only visual in the html editor in f.e. firebug in the front of the website.

You can not see those no break tags in the editor any more, but they are still there causing effects on how the text looks in the front of the website.

Those nbsp codes should not convert to hidden nbsp codes in the text editor. People are not aware of them if they cant see them.

http://i.imgur.com/asyV60s.png

please fix.

Change History (1)

#1 @azaozz
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @BackuPs, thanks for the bug report. It appears to be a duplicate of #26842.

Note: See TracTickets for help on using tickets.