WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#34714 closed defect (bug) (invalid)

WordPress makes changes by itself

Reported by: tashametrano Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: General Keywords:
Focuses: Cc:

Description (last modified by DrewAPicture)

Hi! When I made some changes in my design, my wordpress changes something else by itself in my website. Also the visual editor is not working.

I don't know why is this happen, i have the last version of every plugin, theme and wordpress. I try deactivating every plugin and switching to the default theme and the error still the same. I also changed the host and still the same.

In the console I have only this bug:

JQMIGRATE: Logging is active jquery-migrate.js:21:2
JQMIGRATE: jQuery.fn.live() is deprecated jquery-migrate.js:41:4
console.trace(): jquery-migrate.js:43
migrateWarn() jquery-migrate.js:43
jQuery.fn.live() jquery-migrate.js:471
<anonymous> frontend-builder-scripts.js:2269
.each() jquery.js:2
m.prototype.each() jquery.js:2
<anonymous> frontend-builder-scripts.js:2262
m.Callbacks/j() jquery.js:2
m.Callbacks/k.fireWith() jquery.js:2
.ready() jquery.js:2
J()

I think is because this... the jqmigrate isn't updated.

Change History (8)

#1 @tashametrano
5 years ago

  • Severity changed from normal to critical

#2 @swissspidy
5 years ago

  • Focuses javascript performance removed
  • Severity changed from critical to normal

Hi there and welcome to trac.

Such questions are usually better asked in the support forums, but I'll try to help you here.

When I made some changes in my design, my wordpress changes something else by himself in my website. Also the visual editor is not working.

WordPress itself doesn't just randomly make edit to your website. Can you elaborate on what changes are happening?

Also, how and why is the visual editor not working?

[...]  frontend-builder-scripts.js

That script is not part of WordPress. Please make sure all plugins are deactivated (mu-plugins too!) and you're using one of the default themes? If that file is still enqueued, you should probably re-install WordPress.

Make sure you use an up-to-date browser as well.

#3 @tashametrano
5 years ago

Hi! thanks for your answer, I certainly asked in the support forum but I've no received answer till the moment and this is very urgent for me cause I can't continue work in the website of my office.

I can't provide you the link of my site cause my boss is who control the server and has the site very private so Google can't find our site while we still developing.

I'm using Divi theme from elegantthemes. But I tried switch to default theme and the error still the same. So, what happening is that i'm trying to edit something in the backend of Divi or default theme and when I do the preview of what I edited wordpress not make the changes and other thing I've not edited has change. And this happen with everything, with the layers in the backend, with changes in the Editor, with pages, with post... This happen with everything but most in the pages with more information, like images and text. In the pages with less information, wordpress just not make the changes that I do in the page.

About the visual editor says that cannot connect to the DNS. This occurs in the server of my boss and in the local I've made to replicate the site.

I tried to explain the issue the best I could but my english is not very good. If you can provide me some e-mail I can send you screenshots of what is happening in our site, so you can understand better.

I'm kind of desperate with this issue, I really hope you can help me.

Thanks a lot!!!!

#4 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This sounds like a network misconfiguration. Please speak to your network administrator or your boss as we're unable to provide such support here, especially if the website is not accessible.

If the problem turns out to be an issue with WordPress, please re-open this ticket with further information.

#5 @tashametrano
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi again..

So my boss has checked the DNS and now the visual editor is working again, but the principal issue:

" I'm using Divi theme from elegantthemes. But I tried switch to default theme and the error still the same. So, what happening is that i'm trying to edit something in the backend of Divi or default theme and when I do the preview of what I edited wordpress not make the changes and other thing I've not edited has change. And this happen with everything, with the layers in the backend, with changes in the Editor, with pages, with post... This happen with everything but most in the pages with more information, like images and text. In the pages with less information, wordpress just not make the changes that I do in the page. "

Still here.

#6 @DrewAPicture
5 years ago

  • Description modified (diff)
  • Summary changed from Wordpress make changes by himself to Wordpress make changes by itself

#7 @SergeyBiryukov
5 years ago

  • Keywords close added
  • Milestone set to Awaiting Review
  • Summary changed from Wordpress make changes by itself to WordPress makes changes by itself

In the pages with less information, wordpress just not make the changes that I do in the page.

This sounds like some kind of caching or other environment-specific issue.

Unfortunately, there's not much we can do from the WordPress core side until there are clear steps to reproduce the issue on a clean install.

Please continue with your topic on support forums.

#8 @swissspidy
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.