Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#34730 closed defect (bug) (fixed)

Rename `register_api_field()` to `register_rest_field()`

Reported by: danielbachhuber's profile danielbachhuber Owned by: johnbillion's profile johnbillion
Milestone: 4.4 Priority: normal
Severity: normal Version:
Component: REST API Keywords: has-patch commit
Focuses: Cc:



We'll include a compatibility shim in the plugin for backwards compat.


Attachments (2)

34730.1.diff (683 bytes) - added by danielbachhuber 8 years ago.
Rename register_api_field() to register_rest_field()
34730.2.diff (2.1 KB) - added by danielbachhuber 8 years ago.
Remove register_api_field()

Download all attachments as: .zip

Change History (6)

8 years ago

Rename register_api_field() to register_rest_field()

This ticket was mentioned in Slack in #core by danielbachhuber. View the logs.

8 years ago

#2 @danielbachhuber
8 years ago

  • Keywords has-patch commit added; needs-patch removed
  • Owner set to johnbillion
  • Status changed from new to assigned

8 years ago

Remove register_api_field()

#3 @danielbachhuber
8 years ago

34730.2.diff removes register_api_field() from core, as it's conceptually bound to WP_REST_Controller, which doesn't yet exist in core.

#4 @johnbillion
8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 35687:

Remove register_api_field() from core. This is the only core function that utilises the $wp_rest_additional_fields global, and doesn't belong as part of the infrastructure.


Fixes #34730

Note: See TracTickets for help on using tickets.