WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 7 weeks ago

#34934 reopened defect (bug)

Suppress preg_match() and urldecode() errors in WP::parse_request().

Reported by: entreosos Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.4
Component: Query Keywords: reporter-feedback, bulk-reopened
Focuses: Cc:

Description (last modified by swissspidy)

Error en la fila class-wp.php

207 - 208

Aqui lo arregle asi

if ( @preg_match("#^$match#", $request_match, $matches) || @preg_match("#^$match#", @urldecode($request_match), $matches) ) {

Change History (7)

#1 @swissspidy
3 years ago

  • Description modified (diff)

#2 @SergeyBiryukov
3 years ago

  • Component changed from General to Query
  • Keywords reporter-feedback added

Hi @entreosos, welcome to Trac!

To clarify, the suggestion is to silence preg_match() and urldecode() in WP::parse_request().

Could you please describe the actual issue you're having and provide the steps to reproduce it on a clean install?

Does it still happen with all plugins disabled and a default theme (Twenty Sixteen or Twenty Fifteen) activated?

Does it happen in earlier versions?

#3 @swissspidy
3 years ago

I suspect this happened because of mixed up / broken rewrite rules. Try regenerating them under Options -> Permalinks after disabling all the plugins.

This ticket was mentioned in Slack in #core by wonderboymusic. View the logs.


3 years ago

#5 @SergeyBiryukov
3 years ago

  • Summary changed from Despues de actualizar WP 4.4 tuve error to Suppress preg_match() and urldecode() errors in WP::parse_request().

#6 @iseulde
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This ticket has not seen any activity in over *two* years, so I'm closing it as "wontfix".

The ticket may lack decisiveness, may have become irrelevant, or may not have gathered enough interest.

If you think this ticket does deserve some attention again, feel free to reopen.

For bugs, it would be great if you could provide updated steps to reproduce against the latest version of WordPress (5.0.2 at the time of writing). Remember images or a video can be superior to explain a problem. At the very least, quickly test again to make sure the bug still exists.

If it’s an enhancement or feature, some extra motivation may help.

Thank you for your contributions to WordPress! <3

#7 @JeffPaul
7 weeks ago

  • Keywords bulk-reopened added
  • Milestone set to Awaiting Review
  • Resolution wontfix deleted
  • Status changed from closed to reopened

A decision was made to reopen tickets that were closed in the bulk edit that this ticket was affected by. This ticket is being placed back into the Awaiting Review milestone so it can be individually evaluated and verified to determine if it is still relevant/valid or reproducible.

Note: See TracTickets for help on using tickets.