WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 21 months ago

Last modified 21 months ago

#35125 closed defect (bug) (fixed)

Attachment Details-view not closing when deleting a file after switching from another file

Reported by: Asgaros Owned by:
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.4
Component: Media Keywords: needs-patch
Focuses: javascript, administration Cc:

Description

Hello all,

I found a bug when I try to delete a file in the Media Library from the Attachment Details-view when I switched from another file.

Lets assume there are three different images (red/green/blue) in the Media Library:

http://fs5.directupload.net/images/151216/6zrhnov3.png

When I open the red image, click on the Delete Permanently-link at the Attachment Details-view and confirm the alert, the Attachment Details-view closes and the file is deleted. So far so good.

Now lets assume that we have those three different images (red/green/blue) in the Media Library again ...

Step 1: Open the red image.

Step 2: Switch to the green image via the next file-icon at the top right of the Attachment Details-view.

http://fs5.directupload.net/images/151216/hmcixheg.png

Step 3: Click on the Delete Permanently-link at the Attachment Details-view of the green image and confirm the alert.

http://fs5.directupload.net/images/151216/eqbyo7zr.png

The green image will be removed from the server and from the Media Library-view "behind" the Attachment Details-view, but the Attachment Details-view for the green image will stay open.

Sure, you just can close the Attachment Details-view but it is a little bit confusing because it seems like the file is still there. You can click the Delete Permanently-link and other parts of the Attachment Details-view as well.

This bug occurs on 4.4 & trunk and was tested in Chrome & Edge on different sites.

Change History (4)

#1 @Asgaros
4 years ago

  • Keywords needs-patch added

#2 @joemcgill
3 years ago

  • Milestone changed from Awaiting Review to Future Release

Confirmed that this is still an issue. Additionally, Once you delete the image, the previous/next buttons no longer function as expected.

#3 @wonderboymusic
21 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [41021]

#4 @netweb
21 months ago

  • Milestone changed from Future Release to 4.9
Note: See TracTickets for help on using tickets.