WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35207 closed enhancement (duplicate)

"Filenames to latin" Plugin to Core WordPress

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: has-patch
Focuses: Cc:
PR Number:

Description

I have problem with files uploaded to media library. I have filename "ŻÓŁty koń.jpg". I upload this file and I have problem because I can't show image. Why? Because filename on my server (Windows 10) is "ŻÓŁty-koĹ„.jpg".

I have url http://localhost/wp/wp-content/uploads/2015/12/ŻÓŁty-koń.jpg

When I used plugin "Filenames to latin" (https://wordpress.org/plugins/filenames-to-latin/) then all is OK.

I suggest implement this plugin to core of WordPress. This plugin excluded problem with transfer website to other server / platform.

Attachments (1)

35207.patch (8.4 KB) - added by sebastian.pisula 4 years ago.

Download all attachments as: .zip

Change History (7)

This ticket was mentioned in Slack in #core by sebastian.pisula. View the logs.


4 years ago

#2 @sebastian.pisula
4 years ago

PHP Version 5.5.9. I use XAMPP 3.2.1 on my localhost

#3 @johnbillion
4 years ago

  • Component changed from General to Media
  • Keywords needs-patch added

#4 @sebastian.pisula
4 years ago

  • Keywords has-patch added; needs-patch removed

#5 @Clorith
4 years ago

I do believe remove_accents() already handles the character breakdown appropriately

Passing the file name through that on upload, and then supplying a filter with the before and after names for those who need to do something special, is probably a much better approach than copying over a plugin like this.

#6 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15955 and #22363.

Note: See TracTickets for help on using tickets.