WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#35230 closed defect (bug) (fixed)

Enable full-height editor causes sidebar to be cut off in some situations

Reported by: fliespl Owned by: azaozz
Milestone: 4.6 Priority: normal
Severity: normal Version: 4.3
Component: Editor Keywords: needs-patch
Focuses: ui, administration Cc:
PR Number:

Description

Hi,
I have been able to reproduce this is issue in 4.3 & 4.4. It happens on Chrome (47).

Steps:

  • Enable full-height editor and distraction-free functionality (2 columns)
  • Add a few boxes to right sidebar on post edit page
  • Create a very long post
  • Scroll to the top of the page and then scroll to bottom

http://codeone.pl/ss/ss-2015-12-26_13-26-39-001.png
http://codeone.pl/ss/ss-2015-12-26_13-29-59-001.png

You will notice that sometimes sidebar will not go all the way down and boxes get cut off. In first case you can see "Tags" getting cut off and in the second you can't even publish post (you can clearly see Wordpress version getting into it).

Scrolling a bit up and down solves the issue.

Change History (4)

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


3 years ago

#2 @iseulde
3 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Yeah there seems to be no adjustment when drag and dropping boxes. Thanks for the report!

#3 @azaozz
3 years ago

  • Milestone changed from Future Release to 4.6

#4 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 37659:

Editor, editor-expand: adjust the sidebar position when moving a postbox from one column to another.

Fixes #35230.

Note: See TracTickets for help on using tickets.