Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#35353 closed defect (bug) (duplicate)

Endless loop when canonical URL contains caps

Reported by: rmens Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Canonical Keywords:
Focuses: Cc:

Description

Could reproduces this on 2 sites with 4.4.1

When my site is http://www.johnappleseed.com and i stylize it as http://www.JohnAppleseed.com as the canonical URL, an endless redirect loopt occurs on the homepage.

Wordpress is trying to redirect http://www.johnappleseed.com to http://www.JohnAppleseed.com which the browser opens as url without caps. So Wordpress tries again.

There should be a check which makes this all lower caps.

Change History (3)

#1 follow-up: @kraftbj
6 years ago

Thanks for the report!

I haven't confirmed, but this may be related/same root issue as #35344. @dd32 - does this seem probable based on your research into that bug?

#2 in reply to: ↑ 1 @rmens
6 years ago

Replying to kraftbj:

Thanks for the report!

I haven't confirmed, but this may be related/same root issue as #35344. @dd32 - does this seem probable based on your research into that bug?

Just did some more testing. This only seems to occur when there is a custom post type or blog listing page set as a front page. So probably related/same.

#3 @pento
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #35344.

Note: See TracTickets for help on using tickets.