WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#35548 closed defect (bug) (duplicate)

AllPosts page: Post category can't be removed by "Edit" bulk action

Reported by: antonrinas Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Posts, Post Types Keywords:
Focuses: Cc:
PR Number:

Description

STEPS TO REPRODUCE

  1. Log in as administrator. Create new category for posts "Test category".
  2. Create new post "test post" and assign it to categories "Uncategorized", "Test category".
  3. Go to AllPosts page. Check "test post" and make "Edit" bulk action.
  4. In "Categories" list select "Test category". "Uncategorized" is not checked.
  5. Click "Update".

EXPECTED RESULT: "test post" is assigned only to "Test category".
ACTUAL RESULT: "test post" is assigned to "Test category" and "Uncategorized".

Attachments (1)

AllPosts3.jpg (71.3 KB) - added by antonrinas 4 years ago.

Download all attachments as: .zip

Change History (3)

@antonrinas
4 years ago

#1 @wpnook
3 years ago

As far as I've known, this is the intended behavior. The current UI does not really support the bulk editing of potentially dozens or hundreds of post. It's not a tool to manage your post's categories, but to assign them in bulk. I'm going to create a new ticket that deals with the label verbiage so that it's easier to understand.

#2 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, we're already tracking this issue in #11302.

In the meantime, Batch-Move Posts plugin might be helpful.

Note: See TracTickets for help on using tickets.