WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#35575 closed defect (bug) (duplicate)

Latest nightly build breaks Media Library

Reported by: kouratoras Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Media Keywords:
Focuses: ui Cc:

Description

The latest nightly build update (4.5-alpha-36375) breaks the Media Library page.
The page is empty, the toolbar is not being displayed at all and the "Add New" button is not clickable.

Even if I add an image inside a post, the Media Library page is still empty and broken.

I tried this in a clean WP installation, with no plugin activated and Twenty Sixteen theme.

I downgraded to point release nightly (4.4.2-alpha-36378) and it works as expected.

Attachments (1)

media-library.png (52.0 KB) - added by kouratoras 4 years ago.
Broken Media Library page

Download all attachments as: .zip

Change History (8)

@kouratoras
4 years ago

Broken Media Library page

#1 @pross
4 years ago

Same here, trunk 36375 using chrome, firefox and safari on OSX

Weirdly if you open the inspection tools on any of the tree browsers the media panel appears, close the inspector and it vanishes again

#2 @dimitris.m
4 years ago

Another info that might help is that this is clearly caused by JS as the list view is working properly (wp-admin/upload.php?mode=list)

#3 @ocean90
4 years ago

  • Focuses ui added
  • Keywords reporter-feedback added

Is this still an issue? How many items do you have in the media library?

#4 @kouratoras
4 years ago

  • Keywords reporter-feedback removed

I still have the issue, using the latest nightly build 4.5-alpha-36427.

I checked in a fresh WordPress install, so with no items in the media library.
But even if I add an image in a post, the Media Library page is still empty and broken.

#5 @dimitris.m
4 years ago

Please note that this is kind of resolved with the grid media feature plugin:
https://wordpress.org/plugins/media-grid/

but without it, the Grid view is broken for me too.

#6 @pross
4 years ago

Looks like its fixed for me in trunk 36429

#7 @mikeschroder
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks to be a duplicate of #36083.

If you see this crop up again, feel free to reopen.

Note: See TracTickets for help on using tickets.