WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35708 closed defect (bug) (duplicate)

Add New Post page: creation confirmation message is shown when post was not created

Reported by: antonrinas Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:
PR Number:

Description

STEPS TO REPRODUCE:

  1. Log in as admin.
  2. Go to Add New Post page. Click "Publish" when all fields are not filled.

EXPECTED RESULT:
Post is not created. No confirmation message.
ACTUAL RESULT:
Post is not created. Creation confirmation message is shown (see annexes).

  1. Click "Save Draft" when all fields are not filled.

EXPECTED RESULT:
Draft is not saved. No confirmation message.
ACTUAL RESULT:
Draft is not created. Creation confirmation message is shown (see annexes).

P.S. Perhaps it would be better to disable "Publish" and "Save Draft" buttons if form is not filled or use Java Script validation to avoid unnecessary request to server.

Attachments (3)

new_post_page1.jpg (109.4 KB) - added by antonrinas 4 years ago.
new_post_page2.jpg (107.6 KB) - added by antonrinas 4 years ago.
all_posts_page3.jpg (83.1 KB) - added by antonrinas 4 years ago.

Download all attachments as: .zip

Change History (5)

#1 @EFAREM
4 years ago

I think it kinda makes sense, it saves with status auto-draft in the database and switches to post.php plus the URL includes the created post ID.

I guess it's a little annoying that it doesn't appear in the posts table due to being an auto-draft and if you continually clicked save without any info, navigated away and repeated again and again you'd end up with lots of redundant database lines. The real question is how often will people click save without entering anything anyway?

#2 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17115.

Note: See TracTickets for help on using tickets.