WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#35786 closed defect (bug) (invalid)

Media Uploads in 4.5 Fail

Reported by: Ipstenu Owned by: johnbillion
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Media Keywords:
Focuses: Cc:

Description

Screen Shot 2016-02-09 at 9.59.09 AM.png
An error occurred in the upload. Please try again later.

This happens on all image uploads on the latest build

Change History (13)

#1 @ocean90
5 years ago

  • Keywords reporter-feedback added

From /newticket:

  • What steps should be taken to consistently reproduce the problem?
  • Please provide any additional information that you think we'd find useful. (OS and browser for UI defects, server environment for crashes, etc.)
  • Does the problem occur even when you deactivate all plugins and use the default theme?

Also, which version to you mean by "latest build"? Right now uploads are working in trunk and the latest night for me.

#2 @Ipstenu
5 years ago

Literally upload an image.

  1. Make a new post
  2. DO NOT SAVE THIS POST
  3. Drag/drop media

Gives me an error on 4.5-alpha-36504

#3 @gnotaras
5 years ago

Hi all,

How to reproduce in 4.5-alpha-36505:

  1. Add new post / Edit any post.
  2. Click on the 'Add Media' button.
  3. On the 'Media Library' tab, the retrieval of the image listing never completes.
  4. On the 'Upload Files' tab, any image upload ends with the error An error occurred in the upload. Please try again later..
  5. Nevertheless, if you close the media upload dialog and head to the media library at '/wp-admin/upload.php', you notice that the image has been uploaded and attached to the post (only in post edits).
  6. The edit screen of the attachment seems to be working.
  7. The public attachment page gives a 404 code.

If I notice anything else, I'll let you know.

#4 @gnotaras
5 years ago

OK. I think I'm getting somewhere. If I deactivate the WordPress Beta Tester plugin, which was used to update to the nightly releases, it seems to work. On another test web site I also had to deactivate the Query Monitor plugin.

#5 @gnotaras
5 years ago

Re-tested with 4.5-alpha-36540.

Image uploading (while adding media from post edit screen) / media library listing now works while the WordPress Beta Tester plugin is activated.

Still doesn't work while Query Monitor plugin is activated.

It always worked with Debug Bar.

Last edited 5 years ago by gnotaras (previous) (diff)

#6 @Ipstenu
5 years ago

I've contacted @johnbillion about this one.

Not sure why that would matter. it's breaking ALL of media though (the media library won't even load). Not sure if this is endemic of a core change or of the plugin itself being broken. Seems odd.

#7 @johnbillion
5 years ago

  • Keywords reporter-feedback removed
  • Owner set to johnbillion
  • Status changed from new to assigned

#8 @gnotaras
5 years ago

Not sure if this is endemic of a core change or of the plugin itself being broken. Seems odd.

Hi Mika, indeed it seemed very odd, mainly because of the lack of any error messages.

I just did some more testing and I think I've possibly identified the cause of the problem.

The media listing is not loading possibly because the body of the response to the ajax request contains the following HTML at the end (checked it in firebug's console panel):

<br />
<b>Notice</b>:  is_comments_popup is <strong>deprecated</strong> since version 4.5 with no alternative
 available. in <b>/mywproot/wp-includes/functions.php</b
> on line <b>3661</b><br />

This is a deprecation warning triggered from here. To confirm it, I set WP_DEBUG to false in wp-config.php and then it worked with the Query Monitor plugin enabled.

The above piece of HTML appears in the ajax response body whenever Query Monitor is activated and WP_DEBUG is enabled.

A few days ago, the media library was also not loading when the WordPress Beta Tester plugin was active, but I'm not sure this happened due to the same problem. However, WordPress Beta Tester seems to work with the recent nightly releases without any issues.

I hope I wrote this feedback clear enough. If anyone needs more info, please feel free to ask.

#9 follow-up: @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

[36571] will prevent such things in the future.

#10 in reply to: ↑ 9 @gnotaras
5 years ago

Replying to ocean90:

[36571] will prevent such things in the future.

That's great! Thanks all for taking care of this issue.

#11 @gnotaras
5 years ago

Just for the sake of completeness, I just tested 4.5-alpha-36582 and I no longer can reproduce the problem.

#12 @nomadcoder
5 years ago

I have this error on several websites, I have been monitoring. Thanks for the fix. I'm curious, why was this labeled as invalid?

#13 @gnotaras
5 years ago

I also think this is a very valid bug report. I've also been trying to deal with this issue for several days since the early 4.5 alphas.

Last edited 5 years ago by gnotaras (previous) (diff)
Note: See TracTickets for help on using tickets.