WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#35789 closed defect (bug) (invalid)

Theme screenshots flicker on initial hover with fresh cache in Firefox.

Reported by: JoeFusco Owned by: ocean90
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: General Keywords: has-patch
Focuses: ui Cc:
PR Number:

Description

With a freshly cleared cache, theme screenshot images appear to jump/flicker/flash on the initial hover. This behavior is not intended and can be easily solved by using the will-change property to force hardware acceleration which fixes the initial paint. See: https://developer.mozilla.org/en-US/docs/Web/CSS/will-change

Due to how fast the flicker is, you will only see twentyfifteen and twentyfourteen theme screenshots flicker in the following screencast although all 6 screenshots flickered initially.

screencast: http://quick.as/9yj2sooqn

Steps to reproduce:

  1. Open latest Firefox
  2. Go to src.wordpress-develop.dev/wp-admin/themes.php
  3. Refresh the page and bypass the browser's cache. (Mac cmd + shift + R)
  4. Hover theme screenshots.

Attachments (1)

35789.diff (343 bytes) - added by JoeFusco 4 years ago.

Download all attachments as: .zip

Change History (9)

@JoeFusco
4 years ago

#1 @JoeFusco
4 years ago

See attached solution.

#2 @JoeFusco
4 years ago

  • Keywords has-patch added

#3 @afercia
4 years ago

Thanks @JoeFusco and welcome to Trac! Seems something specific to OSX and webkit browsers, right? Couldn't reproduce on Windows + Chrome. Same for #35787.

#4 @JoeFusco
4 years ago

@afercia Thanks! That is correct. I was not able to reproduce this on Windows 10 Chrome, same goes for #35787 in Firefox. Both issues seem exclusive to OSX (10.11.3). Sorry forgot to include OS on this one.

Last edited 4 years ago by JoeFusco (previous) (diff)

#5 @afercia
4 years ago

  • Owner set to ocean90
  • Status changed from new to assigned

#6 @ocean90
4 years ago

I can't reproduce this issue in Firefox 44.0.2 on OS X 10.11.3 with a Retina screen. Do you have any other plugins installed?

#7 @JoeFusco
4 years ago

  • Resolution set to invalid
  • Status changed from assigned to closed

No plugins or extensions. Turns out I was using 46.0a2 which is not stable. Everything looks fine in 44.0.2. Filed this with Mozilla. See https://bugzilla.mozilla.org/show_bug.cgi?id=1249495#c0

Thanks!

Last edited 4 years ago by JoeFusco (previous) (diff)

#8 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.