WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35811 closed enhancement (duplicate)

user_url length should be increased

Reported by: nevis2us Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Database Keywords:
Focuses: Cc:
PR Number:

Description

Default user_url field length in wp_users table should be increased.

Use case: LinkedIn user profile urls may contain non-ascii user names in utf-8 where each non-ascii character will take at least 6 bytes url-encoded.

Example: cyrillic small letter 'а' becomes %D0%B0.

Current length is 100 so the url may not contain more than 15 non-ascii characters which is a serious restriction.

Suggested new length: 200.

Change History (2)

#1 @swissspidy
4 years ago

See also: #34927

#2 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #34927.

Note: See TracTickets for help on using tickets.