WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#35834 closed feature request (duplicate)

Return post/page permalink in the post object

Reported by: jamesckemp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:
PR Number:

Description

Is there a reason that the post object doesn't contain something like "post_permalink"? If not, I think it'd be useful to have.

Change History (2)

#1 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

At some point in the future WP_Post will be decorated with methods for accessing things such as the Permalink.

Currently the WP_Post instance fields are what exist in the database, nothing extra is there.

I'm closing this as maybelater for now, as there's a long list of things which prevent us adding these methods right now, some of those are covered in this ticket

#2 @dd32
4 years ago

  • Resolution changed from maybelater to duplicate

Duplicate of #12267.

Note: See TracTickets for help on using tickets.