Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#35931 closed enhancement (duplicate)

Enhancements: Umlauts - changing file names

Reported by: torbentschechnegmailcom's profile torben.tschechne@… Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Hello,
I use the german version of WordPress and the permalink is handled fine. When a Word with a special Character as ä,ö,ü,ß is in the permalink, WP changes it to ae, oe, ue, ss which is totally fine.

This enhancement has to be extended for file names as well. A file name of a picture with ä,ö,ü,ß should be renamed as well, otherwise there are often errors with migrations.

A good solution can be found here: https://github.com/bueltge/de_DE.php - but this has to be integrated in core.

Thanks.

Change History (3)

#1 @johnbillion
8 years ago

  • Keywords needs-patch added
  • Version 4.4.2 deleted

#2 @johnbillion
8 years ago

The ring diacritic should be removed too (eg. ). Its urlencoded value is %cc%8a.

#3 @SergeyBiryukov
8 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22363.

Note: See TracTickets for help on using tickets.