WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 months ago

#36444 closed defect (bug) (maybelater)

Site Icon: Previews for Transparent PNGs can appear blank.

Reported by: mikeschroder Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description

If you crop a transparent PNG whose graphic is mostly black, and is transparent, it gets hidden in its app icon preview. This is apparent while cropping in 4.4.x, and both while cropping and in the Customizer sidebar in 4.5.

It's more obvious in WordPress 4.5 due to the move of the app icon/tab preview to the Customizer Sidebar.

https://cloudup.com/cwYzYmAue5i

Logo to test with to be attached shortly.

Attachments (2)

wordpress-logo-hoz-rgb.png (8.9 KB) - added by mikeschroder 5 years ago.
dark-browser-dark-icon.PNG (1.6 KB) - added by celloexpressions 5 years ago.

Download all attachments as: .zip

Change History (4)

#1 @celloexpressions
5 years ago

Not sure if there's much we can do about this. If the image is predominantly light, it won't show up in the browser icon preview. If it's dark it won't show up in the app icon preview. Depending on the device or browser, a transparent icon could very well be hard to see, and that's a risk that the current setup helps content authors be more aware of. See attached example in the MS Edge browser in dark mode.

#2 @mikeschroder
5 months ago

  • Resolution set to maybelater
  • Status changed from new to closed

Checking in on this ticket, I think @celloexpressions's note is accurate.

I'm going to close it as maybelater.

If anyone is experiencing this issue and/or thinks it is an important thing to fix, feel free to reopen.

Note: See TracTickets for help on using tickets.