WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36472 closed defect (bug) (duplicate)

Media Library seems to break

Reported by: coderste Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Media Keywords:
Focuses: Cc:

Description

In WordPress 4.4.2 the media library seems to break completely if I set WP_DEBUG to true - is this the normal behaviour for this?

http://i.stack.imgur.com/wmPCJ.png

Once I disable WP_DEBUG it seems to work just fine and all the images I have uploaded are displayed - this is quite annoying having to turn it off while debugging a feature on my theme.

Change History (6)

#1 in reply to: ↑ description @coderste
4 years ago

  • Keywords needs-testing added
Last edited 4 years ago by coderste (previous) (diff)

#2 follow-ups: @ocean90
4 years ago

  • Keywords close reporter-feedback added; needs-testing removed

Hello @coderste, that's probably because of a PHP warning caused by one of your plugins or a theme which corrupts the XHR response. [36571] will fix this by suppressing the errors.
Can you test if it still happens in RC2 of WordPress 4.5?

#3 in reply to: ↑ 2 @coderste
4 years ago

Replying to ocean90:

Hello @coderste, that's probably because of a PHP warning caused by one of your plugins or a theme which corrupts the XHR response. [36571] will fix this by suppressing the errors.
Can you test if it still happens in RC2 of WordPress 4.5?

I have restored back to the default theme and disabled all Plugins and I seem to get the same result while in debug mode I can not access the media library

#4 in reply to: ↑ 2 @coderste
4 years ago

Replying to ocean90:

Hello @coderste, that's probably because of a PHP warning caused by one of your plugins or a theme which corrupts the XHR response. [36571] will fix this by suppressing the errors.
Can you test if it still happens in RC2 of WordPress 4.5?

I've tested this in 4.5 and while in debug mode the media library does work - I can it was just a 4.4 bug

#5 @coderste
4 years ago

  • Keywords reporter-feedback removed

#6 @ocean90
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26262.

Thanks for testing!

For your 4.4 install I suggest to inspect the response of the XHR request in your browser. Should be visible in the network tab of the developer tools.

Note: See TracTickets for help on using tickets.