WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#36777 closed defect (bug) (duplicate)

Grid view not working after upgrading to Wordpress v4.5.1

Reported by: johncove Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Media Keywords:
Focuses: Cc:

Description

Hi,

The grid view in the media library no longer works after an update from Wordpress v4.5 to Wordpress v4.5.1

I have tried:-

  1. Recreating .htaccess file
  2. Switching to a different theme
  3. Uploaded a new wp-includes folder with contents from the Wordpress download site
  4. Disabled all plugins

The list view is working but the grid view has stopped working - I get a spinning circle forever with no media shown.

Can someone help please.

Attachments (1)

2016-05-06_16h50_42.jpg (18.6 KB) - added by johncove 2 years ago.

Download all attachments as: .zip

Change History (12)

#1 @adamsilverstein
2 years ago

@johncove welcome to trac, thanks for the bug report!

can you give the browser/version and operating system you are using to access you site? Also, can you open the debugger console to see if there are any errors? also, please try activating the default (twenty sixteen) theme to ensure its not a theme compatibility issue.

#2 @kencook
2 years ago

Multiple possibilities for this one. It could be as simple as doing a WP database repair http://codex.wordpress.org/Editing_wp-config.php#Automatic_Database_Optimizing for more. Also, check to see if you have media files attached to non-existent posts/pages. Both of these are generally not an issue, but either is a possibility.

#3 follow-ups: @johncove
2 years ago

I've now tried:-

  1. Twenty Sixteen theme and switched from this and back to the original theme
  2. Repaired the db using PHPMyAdmin

The above did not work.

I have tried Chrome v50.0.2661.94 m and Edge v25.10586.0.0 on Windows 10 (my client has used Windows 7 with differing versions of browsers).

Console gives me the following errors:-

www.www.kompassinfo.co.uk/:2 Uncaught SyntaxError: Unexpected token <

Thanks!

This ticket was mentioned in Slack in #core-images by joemcgill. View the logs.


2 years ago

#5 in reply to: ↑ 3 @joemcgill
2 years ago

@johncove Do you have any other plugins active? If so, can you try disabling them and/or reproducing on a clean install of WordPress. I'm not able to reproduce this locally, so I'm wondering if something is interfering or if you have a corrupt file in your install.

Replying to johncove:

I've now tried:-

  1. Twenty Sixteen theme and switched from this and back to the original theme
  2. Repaired the db using PHPMyAdmin

The above did not work.

I have tried Chrome v50.0.2661.94 m and Edge v25.10586.0.0 on Windows 10 (my client has used Windows 7 with differing versions of browsers).

Console gives me the following errors:-

www.www.kompassinfo.co.uk/:2 Uncaught SyntaxError: Unexpected token <

Thanks!

#6 @johncove
2 years ago

I have disabled all plugins and the problem still persists :/

#7 @johncove
2 years ago

So, I installed a fresh Wordpress installation and reinstalled the wp-content directory but still the problem persists.

I don't know what to try next. Please help.

#8 follow-up: @johncove
2 years ago

I get the following on the Media Library page when enabling the debug switch:-

Warning: ini_set() has been disabled for security reasons in /home/kico/public_html/wp-includes/load.php on line 292

Strict Standards: Declaration of Menu_With_Description::start_el() should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /home/kico/public_html/wp-content/themes/kompass/functions.php on line 285

Notice: The called constructor method for WP_Widget in EPS_Super_Search_Widget is deprecated since version 4.3.0! Use construct() instead. in /home/kico/public_html/wp-includes/functions.php on line 3718

Notice: The called constructor method for WP_Widget in randomtext is deprecated since version 4.3.0! Use construct() instead. in /home/kico/public_html/wp-includes/functions.php on line 3718

Notice: The called constructor method for WP_Widget in aibwp_adsBannerWidget is deprecated since version 4.3.0! Use construct() instead. in /home/kico/public_html/wp-includes/functions.php on line 3718

#9 in reply to: ↑ 3 @adamsilverstein
2 years ago

Console gives me the following errors:-

www.www.kompassinfo.co.uk/:2 Uncaught SyntaxError: Unexpected token <

@johncove

this error looks like what you would get when you are displaying PHP errors/notices and you make an ajax request that shows an error, breaking the ajax response. Any chance you have WP_DEBUG_DISPLAY enabled in your wp-config.php file? If so try setting to false and see if that resolves your issues. you will need to have an error/warning free display and ajax response to have that on and have things work. if that doesn't help can you provide a screenshot with the error open in your console?

#10 @johncove
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I found the problem. The hosting platform didn't have ini_set enabled in their config file.

As soon as this was enabled, related Wordpress features worked once again.

Nightmare !!

Only affected the site since Wordpress v4.5

#11 in reply to: ↑ 8 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate
  • Version changed from 4.5.1 to 4.5

Replying to johncove:

I get the following on the Media Library page when enabling the debug switch:-

Warning: ini_set() has been disabled for security reasons in /home/kico/public_html/wp-includes/load.php on line 292

This issue is handled in #36708.

Note: See TracTickets for help on using tickets.