WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#36957 closed defect (bug) (duplicate)

Dialog to add Featured Images doesn't work when resizing images first

Reported by: pauljacobson Owned by: joemcgill
Milestone: Priority: normal
Severity: normal Version: 4.5.2
Component: Media Keywords:
Focuses: ui, administration, performance Cc:
PR Number:

Description

I noticed that when I upload an image to use as a featured image and resize it before clicking on the "Set Featured Image" button, clicking on that button doesn't actually load the preview of the Featured Image. Instead, I have to –

  1. resize the image,
  2. cancel the edit to return to the Media Library and
  3. then re-select the (resized) image and click on the "Set Featured Image" for the preview to load.

Change History (4)

#1 @joemcgill
3 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.6
  • Owner set to joemcgill
  • Status changed from new to accepted

Hi @pauljacobson, thanks for the report. I can confirm that this is the case. It looks like the model isn't being maintained after the edit process, causing wp.media.view.Toolbar.refresh() to throw and undefined error.

#2 follow-up: @joemcgill
3 years ago

  • Keywords needs-patch removed
  • Milestone 4.6 deleted
  • Resolution set to duplicate
  • Status changed from accepted to closed

Actually, this looks like it's a duplicate of #36861, and is fixed by the 36861.2.diff.

#3 in reply to: ↑ 2 ; follow-up: @pauljacobson
3 years ago

Thanks Joe

So does that mean the bug will be fixed in a bug fix update?

Replying to joemcgill:

Actually, this looks like it's a duplicate of #36861, and is fixed by the 36861.2.diff.

#4 in reply to: ↑ 3 @joemcgill
3 years ago

Replying to pauljacobson:

Thanks Joe

So does that mean the bug will be fixed in a bug fix update?

#36861 is currently slotted for 4.5.3, so as long as that fix is completed before that bugfix release goes out, it should be included. Testing out the latest patch on that ticket and leaving feedback would be appreciated.

Note: See TracTickets for help on using tickets.