Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#37036 closed defect (bug) (invalid)

Error in JSON Data from admin-ajax.php

Reported by: baekerIT Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

We've got a problem with our WooCommerce eShop:

It's not longer possible to get the Grid view functional.

In Webdeveloper i saw, that the JSON response from admin-ajax.php is incorrect and throws an Error.

WP-Debug, Plugins everything deactivated and activated again - the System is Windows Server 2012.

In List View, there are no problems - but my customer cannot use the Grid View to add Product Images e.g.

Attachments (1)

2016-06-06.png (167.4 KB) - added by baekerIT 6 years ago.

Download all attachments as: .zip

Change History (9)

#1 @swissspidy
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there,

WordPress Trac is for tracking bugs and enhancements in WordPress itself. For problems with WooCommerce, please us the plugin's support forums: https://wordpress.org/support/plugin/woocommerce

#2 @baekerIT
6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi,

sure, but the Bug is in the Media Library, not in WooCommerce.

When clicking the Media Overview, the round circle loads permanent.

I'll attach a screenshot for you.

@baekerIT
6 years ago

#3 @lukecavanagh
6 years ago

How many product images do you have in the media library on that site. Also what is the memory limit defined as in wp-config.php?

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Last edited 6 years ago by lukecavanagh (previous) (diff)

#4 @baekerIT
6 years ago

There are 432 Entrys at the Moment, Memory Limit is not defined in wp-config - but it is set to 1 GB (WP System Health)

#5 @ocean90
6 years ago

  • Keywords reporter-feedback added
  • Milestone set to Awaiting Review

@baekerIT Does it still happen with all plugins disabled and a default theme activated?

#6 follow-up: @baekerIT
6 years ago

@ocean90 I've to wait for the Serveradmin to create a development Database for testing.

Otherwise: This Problem appeared from one day to another. So I've just fount out that the Problem appeared, when the actual Childtheme is used. With the Parent Theme activated, the Media Library fully works. Thanks :)

#7 in reply to: ↑ 6 @ocean90
6 years ago

Replying to baekerIT:

So I've just fount out that the Problem appeared, when the actual Childtheme is used.

@baekerIT Sounds like the child theme has a file with a byte order mark inserted. You can try to re-save all files as UTF-8 without BOM using Notepad++ or another editor. I'd start with functions.php.

#8 @rachelbaker
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
  • Version 4.5.2 deleted

@baekerIT Going to close this ticket again, since it sounds like you traced the cause to your child theme.

Note: See TracTickets for help on using tickets.