WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37039 closed defect (bug) (fixed)

Cannot Upload New Media Via "Select Files" On Microsoft Edge Browser

Reported by: dimensionmedia Owned by: azaozz
Milestone: 4.6 Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: javascript Cc:

Description

  1. In your Microsoft Edge browser, go to the "Upload New Media" page.
  2. Attempt to click "Select Files".
  3. Nothing happens.

Note: This was discovered on a real, but simulated Windows 10 install via https://app.crossbrowsertesting.com and has been confirmed by other (human) sources.

Tested On:
Windows 10
Microsoft Edge 25.105
Microsoft EdgeHTML 13.105

Screenshot of the screen (which showcases possible relevant errors on the console):

https://www.dropbox.com/s/pgkacnqel1v4vqj/Screenshot%202016-06-06%2016.53.34.png?dl=0

Screenshot of the version number:

https://www.dropbox.com/s/r4jax1cb00v5yil/Screenshot%202016-06-06%2017.08.33.png?dl=0

Tested / latest version of WP with TwentyFourteen theme.

This problem does NOT seem to be appearing on IE 11. Apologizes in advance if this is a duplicate ticket (tried a few searches).

Attachments (1)

37039.patch (2.7 KB) - added by azaozz 3 years ago.

Download all attachments as: .zip

Change History (5)

#1 @afercia
3 years ago

  • Focuses javascript added
  • Milestone changed from Awaiting Review to 4.6
  • Version trunk deleted

Confirmed and as far as I can tell it appears to be caused by at least two reasons:

  • seems in Edge the "Select Files" button doesn't have a click event attached, this appears to be more a plupload/Edge issue
  • on first page load, the "moxie-shim" hidden file input is misplaced (and this happens in all browsers), see screenshot below:

https://cldup.com/QCGpCFEIs3.png

I'm not so into the plupload internals but I think the "shim" is supposed to have a correct position in order to make plupload work in all browsers. The misplacement probably happens because the whole "drop zone" is initially hidden and doesn't have a "size" so plupload is unable to correctly calculate the absolute position to set on the "shim". Clicking on the "lightblue" area highlighted in the screenshot works.

Even on the plupload examples page http://www.plupload.com/examples seems the click event is missing in Edge and the example there works just because the hidden "shim" is correctly positioned.

Worth noting that switching to the "browser uploader" and then switching back to the "multi-file" uploader makes the "moxie-shim" have a correct position:

https://cldup.com/VUBnp_81RP.png

The part related to the event should be probably fixed upstream. In order to mitigate the issue WordPress should maybe change some CSS to ensure the drop zone has an initial size. I'd like to have a second opinion though. /cc @azaozz

#2 @azaozz
3 years ago

Confirmed too. Also confirmed the click event is not bound in Edge, will pass that upstream.

We need to run refresh() to fix the positioning of the shim. Seems that was never added to the click handler for the "Add" button in the page title. Also need to refresh on postinit.

Last edited 3 years ago by azaozz (previous) (diff)

@azaozz
3 years ago

#3 @azaozz
3 years ago

37039.patch should fix this.

#4 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 37722:

Media: properly refresh the position of the Plupload shim so it moves over the Select Files button or off the screen. Fixes selecting files in MS Edge on the Media grid and Media -> Add New screens.

Fixes #37039.

Note: See TracTickets for help on using tickets.