WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37070 closed defect (bug) (duplicate)

Misleading error message in login.php

Reported by: yetAnotherDaniel Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.2
Component: Login and Registration Keywords:
Focuses: Cc:

Description

After changing the process of registration in 4.3 an error message is confusing in the case somebody registers and then immediately tries to login. Then the error message states:
"ERROR: The password you entered for the username abc is incorrect..."

That is misleading because the user did not activate the account and not set a password yet. The message in this case should be something like:
"You did not yet activate your account and set a password. Please check your email."

I get emails from users that are trying to register, don't check their emails and then try to login (I guess they take their usual password). They are confused by the error message. Yes, it is written to check the email after registration but how many users really read carefully all this stuff today?

Change History (2)

#1 @yetAnotherDaniel
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38769.

#2 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.