WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37163 closed defect (bug) (duplicate)

Invalid filename after upload

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upload Keywords:
Focuses: Cc:

Description

I have two problems during upload:

  1. I have filename: FitEasy-Konkurs-Koktajle-po-obróbce-6070.jpg. After upload file is saved in wp-content/uploads with invalid filename: FitEasy-Konkurs-Koktajle-po-obróbce-6070-300x199.jpg. Very important: this char: (ASCII: 111) not is a polish ó (ASCII: 195).
  1. So problem is with filename with polish chars: ĘÓĄŚŁŻŹĆŃęóąśłżźćń.jpg. After upload in uploads dir I can see ĘÓĄŚŁŻŹĆŃęóąśłżźćń.jpg. So I cant see preview because this can't find file in serwer.

Problem is in Windows 10, PHP Version 5.5.9, Apache/2.4.7 (Win32) OpenSSL/1.0.1e PHP/5.5.9

If I use Filenames to latin plugin second problem not exists but exists first problem.

I think that WordPress should take care that uploaded filenames should be valid without use other plugins. I think that this is important error with upload.

Attachments (1)

Remove_Special_Chars_from_filename__first_error_.patch (1.0 KB) - added by sebastian.pisula 3 years ago.

Download all attachments as: .zip

Change History (2)

#1 @Clorith
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15955.

Note: See TracTickets for help on using tickets.