WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 4 weeks ago

#37232 closed defect (bug) (invalid)

Bulk action undefind on admin edit.php

Reported by: LocalGhost-IL Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: administration Cc:
PR Number:

Description

Hey,
I am add a new user role.
He can edit only cpt spcific.
I think is because he not have cap to delete_posts and edit_posts (only edit_cpts) so I get php notice:

Notice: Undefined property: stdClass::$delete_posts in wp-admin/includes/class-wp-posts-list-table.php on line 403
Call Stack
#	Time	Memory	Function	Location
1	0.0014	371160	{main}( )	...\edit.php:0
2	2.1659	85859776	WP_List_Table->display( )	...\edit.php:347
3	2.1659	85859968	WP_List_Table->display_tablenav( )	...\class-wp-list-table.php:1126
4	2.1661	85860232	WP_List_Table->bulk_actions( )	...\class-wp-list-table.php:1183
5	2.1661	85860440	WP_Posts_List_Table->get_bulk_actions( )	...\class-wp-list-table.php:439

It's start on this code line (wp-admin/edit.php:347):


<?php $wp_list_table->display(); ?>

Thank you!

Change History (2)

#1 @desrosj
6 months ago

  • Keywords close reporter-feedback added

Hi @LocalGhost-IL,

Welcome to Trac! And thanks for opening this ticket. My apologies that it took so long to receive a response.

Are you experiencing this issue? In order for someone to debug, you'd need to provide more details. How did you add the new user role? How are you granting capabilities to that role? What action are you taking to produce this error? Please be as specific as possible.

Since this seems like an issue with the custom role you have created, I am goign to mark this as a candidate to close pending your feedback.

#2 @desrosj
4 weeks ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Going to close this out due to lack of reporter-feedback.

If someone is still experiencing this and is able to provide detailed steps to reproduce, it can be reopened and investigated.

Note: See TracTickets for help on using tickets.