WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37236 closed defect (bug) (invalid)

WordPress 4.4.3 upgrade produces blank page

Reported by: earl.fogel Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

I upgraded to WordPress 4.4.3 using the SSH SFTP Updater plugin. The upgrade seems to have worked but at then end I received a blank page and some errors appeared in the log:

[Wed Jun 29 10:34:33 2016] [error] [client 10.80.30.11] PHP Fatal error: Cannot redeclare class WP_Roles in /var/www/html/wp-includes/class-wp-roles.php on line 26, referer: https://words.usask.ca/wp-admin/network/update-core.php?action=do-core-upgrade&_wpnonce=5a5e0e60d0
[Wed Jun 29 10:34:33 2016] [error] [client 23.253.239.79] PHP Fatal error: Cannot redeclare class WP_Roles in /var/www/html/wp-includes/class-wp-roles.php on line 26
[Wed Jun 29 10:34:33 2016] [error] [client 128.233.210.6] PHP Fatal error: Cannot redeclare class WP_Roles in /var/www/html/wp-includes/class-wp-roles.php on line 26
...

Change History (4)

#1 @lukecavanagh
4 years ago

Very odd.

https://github.com/WordPress/WordPress/blob/master/wp-includes/class-wp-roles.php#L26

Have you tried manually updating WordPress to see if that fixes the issue?

#2 @earl.fogel
4 years ago

I unpacked the zip file and did a diff on the two folders.

The only thing that sticks out is that the twentysixteen theme wasn't installed, but I can do that manually. Everything else is the same as what's in the zip file.

Wordpress seems to be working fine, the errors only appeared during the upgrade.

Last edited 4 years ago by earl.fogel (previous) (diff)

#3 @michalzuber
4 years ago

Same issue with version 4.2.7, installed long time ago, just auto updates.
wp-includes/capabilities.php still has WP_Roles

http://i.imgur.com/qLTGd0U.jpg

#4 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Unfortunately I have to mark this as invalid as this scenario is caused by an incomplete upgrade which we either couldn't finish, or were interrupted in the upgrade process.

Additionally, during the upgrade the website may also fatal, which appears to be the original report here, as WordPress is in a state where it's not 100% complete.

Note: See TracTickets for help on using tickets.