WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#38094 closed enhancement (duplicate)

Support for Custom taxonomies autocomplete in inline/bulk edit forms

Reported by: shadyvb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Focuses: ui, javascript, administration Cc:

Description

Currently only Tags are using autocomplete in inline/bulk edit screens, custom taxonomies can use the same flow to enable autocomplete for them as well.

This has been proposed in https://core.trac.wordpress.org/changeset/13535 in response to https://core.trac.wordpress.org/ticket/9674 but seems to not have been merged ( 7 years old patch ).

Attachments (2)

custom-taxos-inlineedit.patch (960 bytes) - added by shadyvb 3 years ago.
Patch to enable autocomplete for custom taxes in inline/bulk edit forms
custom-taxos-inlineedit-all-cpts.patch (960 bytes) - added by shadyvb 3 years ago.
Another patch to enable autocomplete for custom taxos for all post types in inline/bulk edit forms

Download all attachments as: .zip

Change History (6)

@shadyvb
3 years ago

Patch to enable autocomplete for custom taxes in inline/bulk edit forms

@shadyvb
3 years ago

Another patch to enable autocomplete for custom taxos for all post types in inline/bulk edit forms

#1 @shadyvb
3 years ago

Sorry, briefly misunderstood the type argument, the second patch is not really needed, the first one works pretty fine with custom post types.

#2 @swissspidy
3 years ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to 4.8

#3 @jubstuff
2 years ago

It seems to me that this was already solved in r38797.

@shadyvb could you please check if that's the case?

#4 @afercia
2 years ago

  • Keywords needs-testing removed
  • Milestone 4.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.7 deleted

Duplicate of #33902.

Thanks @jubstuff yep, the old jQuery suggest has been replaced in WordPress 4.7 with a custom implementation of jQuery UI autocomplete, which is also accessible, and works for any non-hierarchical taxonomy. @shadyvb please see in the screenshot below, where it's working for a "Project type" taxonomy.

https://cldup.com/4bKTaFX5Nu.png

I think this can be closed, unless I'm missing something :)

Note: See TracTickets for help on using tickets.