WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#38290 closed defect (bug) (invalid)

#1273 - Unknown collation: 'utf8_unicode_520_ci'

Reported by: immujune30 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: General Keywords:
Focuses: Cc:

Description

HI,

I have developed my website in localhost and when i tried to move the site to my server.

On the database when i tried to upload my database file it is raising #1273 - Unknown collation: 'utf8_unicode_520_ci' error.

I developed my site on the latest version of wordpress 4.6.1

And after googling i came to know the sites developed on 4.5.4 below versions of wordpress are not raising any issues while uploading into the server database.

Attachments (1)

screenshot-192.185.190.97 2082 2016-10-12 12-28-51.png (44.1 KB) - added by immujune30 5 years ago.
database file upload error

Download all attachments as: .zip

Change History (4)

@immujune30
5 years ago

database file upload error

#1 @pareshradadiya
5 years ago

I Just replace all utf8_unicode_520_ci with utf8_unicode_ci in db dump file. Then I was able to import the database.

You can try replace utf8mb4_unicode_ci with utf8_unicode_ci

#2 @immujune30
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

At last i have solved it, but database collation replace utf8_unicode_520_ci with utf8_unicode_ci is didn't worked from me.

Thanks for the response @pareshradadiya.

My solution is something as follows.

  1. I have checked my localhost and my server db collation and make it same first of all.

In my case i changed it to 'latin1_swedish_ci' ( we can find this in operations -> on the bottom right side "collation"

  1. after making the db collation same from both ends i.e your localhost db and your server db. download the database in mysql40 format.
  2. now upload the database into the server. ( it should upload without collation errors now, if not follow the 4th step )
  1. If it raising syntax error regarding InnoDB.
  1. then follow the instructions provided in the link

http://stackoverflow.com/questions/9620439/syntax-error-when-running-a-mysql-create-table-statement

  1. Replace Instead of TYPE=INNODB set Engine=InnoDB. and upload the database again.

That's it. In this way It should work 100%.

As per my knowledge the problem is with the hosting mysql version and your localhost mysql version, and wordpress also enhanced its wordpress database tables from the wordpress 4.5.4 versions and above.

other alternative solution is

you can develop your website in localhost on the wordpress 4.5.4 version and make it upgrade at your server. It will not make any db collation issues while uploading.

Thanks

#3 @swissspidy
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.