WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#38775 closed defect (bug) (invalid)

Left double quote (“) character displays poorly in italic versions of Libre-Franklin font

Reported by: colin301 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The “ character is problematic in italic versions of Libre-Franklin font used by twentyseventeen theme.
The two quote marks seem to display on top of one another. At body text size the left double quote is pretty much indistinguishable from the left single quote.

Attachments (1)

bad-glyph.jpeg (67.3 KB) - added by colin301 5 years ago.

Download all attachments as: .zip

Change History (4)

@colin301
5 years ago

#1 @laurelfulford
5 years ago

Nice catch, @colin301!

I'm able to recreate this issue with the font, both in Google Fonts and in Twenty Seventeen.

Unfortunately, it's not something we can fix on the theme level without replacing the entire font. This is a big change to make this close to RC, both in the code and design - I'm worried it could introduce new issues. @melchoyce - what are your thoughts on this?

Libre Franklin also has its own GitHub repo - this would be good to report there, so the issue is on record and can be fixed in the font: https://github.com/impallari/Libre-Franklin

#2 @melchoyce
5 years ago

+1 to reporting to the Libre Franklin repo.

#3 @davidakennedy
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks @colin301!

Reported:

https://github.com/impallari/Libre-Franklin/issues/18

Closing this out since this should be fixed within the font itself.

Note: See TracTickets for help on using tickets.