WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#38826 closed defect (bug) (invalid)

Twenty Seventeen theme: Fix backwards compatibility for Google Fonts preconnect

Reported by: webmandesign Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The twentyseventeen_resource_hints function is not compatible with pre-4.7 WordPress wp_resource_hints filter hook.

Change History (6)

#1 @swissspidy
3 years ago

  • Component changed from Themes to Bundled Theme

AFAIK Twenty Seventeen is only meant to be compatible with 4.7 and newer.

#2 @webmandesign
3 years ago

Oh, OK. I have a patch for that already, so, no need to submitting it, right?

#3 @sami.keijonen
3 years ago

No need, check inc/back-compat.php. But other default themes should work pre-4.7. There is a little bit different code for that.

#4 @webmandesign
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#5 @webmandesign
3 years ago

Thanks for explaining and sorry for not realizing the theme is not backwards compatible.

#6 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted

@webmandesign No worries, thanks for taking the time to create a ticket nonetheless!

Note: See TracTickets for help on using tickets.