WordPress.org

Make WordPress Core

Opened 4 months ago

Last modified 3 days ago

#38953 assigned defect (bug)

Customize Menus: clicking outside of the available menu items panel does not close the panel

Reported by: celloexpressions Owned by:
Milestone: 4.7.4 Priority: normal
Severity: normal Version: 4.6.1
Component: Customize Keywords: good-first-bug has-patch needs-testing
Focuses: javascript Cc:

Description

When the available menu items panel is open, clicking anywhere outside of the panel except for on the menu-item-delete buttons should (and used to) close the panel. In particular, clicking on the preview and clicking on an added menu item to expand its options currently do not close the available menu items panel, but clicking elsewhere in the customize pane works.

Verified that this behavior exists in 4.6.1, so it was a regression some time before 4.7.

Attachments (3)

38953.patch (1.5 KB) - added by rockwell15 4 months ago.
Added pointer-events none to preview iframe when the available menu items panel is open. Then closes the panel on #customize-preview & .menu-item-handle click
38953.2.diff (1.5 KB) - added by westonruter 4 months ago.
38953.diff (1.2 KB) - added by maguiar 4 days ago.
Fixes menu delete button and prevents available menu items from closing when removing an item

Download all attachments as: .zip

Change History (17)

@rockwell15
4 months ago

Added pointer-events none to preview iframe when the available menu items panel is open. Then closes the panel on #customize-preview & .menu-item-handle click

#1 @rockwell15
4 months ago

  • Keywords has-patch added; needs-patch removed

@westonruter
4 months ago

#2 @westonruter
4 months ago

  • Owner set to westonruter
  • Status changed from new to accepted

#3 @westonruter
4 months ago

@celloexpressions does this get your 👍?

#4 @celloexpressions
4 months ago

  • Keywords commit added

38953.2.diff looks good and works in my testing. Still not sure when/how this broke.

#5 @westonruter
4 months ago

Just checked and it's been this way since at least 4.5.

#6 @westonruter
4 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 39548:

Customize: Collapse available nav menu items panel when clicking outside over preview or over existing items.

Props rockwell15.
Fixes #38953.

#7 @celloexpressions
3 months ago

  • Keywords needs-patch added; has-patch commit removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

This change broke the bulk-delete functionality. The available menu items panel can't be closed if the click is on the item-delete button within the menu item handle.

Again, the specific functionality that this ticket looks to restore previously worked, and I specifically remember adding the check for the delete button too. Not sure what happened to it.

This ticket was mentioned in Slack in #core-customize by melchoyce. View the logs.


3 weeks ago

#9 @melchoyce
3 weeks ago

  • Milestone changed from 4.8 to 4.7.4

#10 @celloexpressions
2 weeks ago

  • Focuses javascript added
  • Keywords good-first-bug added

Since this was committed to trunk previously, two things are now required:

  • Amend the trunk fix to not close the panel when the delete buttons are activated. (good-first-bug, needs a patch)
  • Back-port both commits to the 4.7 branch.

#11 @westonruter
7 days ago

  • Owner westonruter deleted
  • Status changed from reopened to assigned

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


5 days ago

@maguiar
4 days ago

Fixes menu delete button and prevents available menu items from closing when removing an item

#13 @maguiar
4 days ago

  • Keywords has-patch added; needs-patch removed

#14 @westonruter
3 days ago

  • Keywords needs-testing added
Note: See TracTickets for help on using tickets.