WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 days ago

#39143 closed defect (bug) (invalid)

Follow up: Inline svg icons are not displaying when the page is viewed from Customizer's iframe on the initial load

Reported by: johndoedoe Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Customize Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

This is a follow-up to #35824.
This behavior still happens, but only on the first load. After clicking on the links inside the iframe and going to other pages, the svg elements start working properly.

Attachments (2)

svg-visible.png (330.8 KB) - added by westonruter 3 years ago.
39143.test-case.diff (1.1 KB) - added by westonruter 3 years ago.

Download all attachments as: .zip

Change History (7)

#1 @johndoedoe
3 years ago

  • Summary changed from Follow up: Inline svg icons are not displaying when the page is viewed from Customizer's iframe to Follow up: Inline svg icons are not displaying when the page is viewed from Customizer's iframe on the initial load

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


3 years ago

#3 @celloexpressions
3 years ago

  • Milestone changed from Awaiting Review to Future Release

Since we thought this was fixed in 4.7 but it wasn't, this isn't a 4.7 regression. Let's try to find a fix in a future release, potentially 4.8 if we can track it down.

#4 @westonruter
3 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Future Release to Awaiting Review

@johndoedoe I just tried to replicate the issue in Chrome but I got nothing. I applied 39143.test-case.diff and was able to see the SVN image appear on the first load of the customizer as in svg-visible.png. Please upload a patch that demonstrates the issue.

#5 @dlh
7 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing for lack of feedback and steps to replicate.

Note: See TracTickets for help on using tickets.