WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#40887 closed defect (bug) (duplicate)

Rendering oembed urls in revisions endpoint post content.

Reported by: kosso Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: REST API Keywords:
Focuses: Cc:

Description

Is there any reason why supported oembed urls are not rendered in the post[].content.rendered JSON data for wp/v2/posts/POST_ID/revisions?

(This is being accessed by a client site/app using a valid wp_nonce query parameter.)

Change History (4)

#1 @TimothyBlynJacobs
3 years ago

I think this was fixed in #40626. It looks like the oEmbed controller is looking for the global post in the shortcode callback. Does the error still occur on the latest Release Candidate.

#2 @kosso
3 years ago

Confirmed. Issue resolved in 4.8-RC1-40853.

Thanks.

#3 @kosso
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#4 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate
  • Version changed from 4.7.5 to 4.7

Duplicate of #40626.

Note: See TracTickets for help on using tickets.