WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#40980 closed defect (bug) (duplicate)

Text Widget Visual Editor breaks formatting on html

Reported by: DavyH Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Widgets Keywords:
Focuses: accessibility, administration, performance Cc:
PR Number:

Description

Unlike editing pages, the new widget visual editor on 4.8 will break HTML formatting on new and existing text widgets when switching back and forth (even without saving).

Also of note (though this is probably a wpautop thing): on our installation, this also started adding <br> and <p> tags around comments and empty spaces where there were none before (we disable wpautop globally); we haven't had time to investigate so I can't be sure this visual editor is the cause, but it was worth noting.

Change History (1)

#1 @westonruter
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Welcome. This has been previously reported in #40951. Please watch that ticket.

Note: See TracTickets for help on using tickets.