WordPress.org

Make WordPress Core

#41481 closed enhancement (duplicate)

Support subfolders in mu-plugins

Reported by: onnimonni Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Currently we are able to load plugins and themes from subfolders like

wp-content/plugins/plugin-subfolder

but somehow we don't use the same logic for mu-plugins.

I would want

wp-content/mu-plugins/plugin-subfolder

to act in similiar manner.

I have been using bedrock-autoloader.php for long time for this but I think it's finally time to support this feature without extra hacks.

For example if I use a hack like bedrock-autoloader.php the wp-cli won't list the used mu-plugins from subfolders as activated mu-plugins causing confusion for admins.

Supporting subfolders from mu-plugins helps using dependency managers like composer.

Links:
https://github.com/roots/bedrock/blob/master/web/app/mu-plugins/bedrock-autoloader.php

Change History (1)

#1 @SergeyBiryukov
22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #14359.

Note: See TracTickets for help on using tickets.