WordPress.org

Make WordPress Core

#41686 closed defect (bug) (duplicate)

Store Widgets in the Posts table

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords: needs-patch needs-unit-tests
Focuses: performance Cc:

Description

Currently widgets are stored in the options table. They can be accessed using WP_Widget. But storing it options has a number of drawbacks, most of which is performance. Migrating the data to the posts table as a new post type has a number of benefits.

  • Revisions for widgets
  • Author
  • Date created / edited
  • Trashing widgets
  • Interact with widgets using the posts endpoint
  • Easier migration of data using the wordpress exporter
  • Post meta for widgets for better extending.

Change History (1)

#1 @ocean90
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #35669.

Note: See TracTickets for help on using tickets.