WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41823 closed defect (bug) (duplicate)

Text on web site during update of plugins and at login page is always in english

Reported by: dragy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: I18N Keywords:
Focuses: Cc:
PR Number:

Description

Hello

during maintenance mode when updating plugins, text on web page is always in english. The text is "Briefly unavailable for scheduled maintenance. Check back in a minute.".

Also text on login page is in english "Username or Email, Password, Remember Me, Log In, Lost your password" etc.

After login text is in set language (set by Settings - General - Page language).

Let me know if I can debug this more somehow.

Change History (12)

#1 @audrasjb
2 years ago

Hello,
Thanks for this ticket, and I agree with you.
But as these strings are correctly internationalized, I think the issue is surely more difficult to solve than we can think at a glance…

<?php _e( 'Briefly unavailable for scheduled maintenance. Check back in a minute.' ); ?>

Edit: This is probably because the WordPress bootstrap is not loaded at this time, or this kind of problem in any case. Not sure this can be solved easily :\

Last edited 2 years ago by audrasjb (previous) (diff)

#2 @SergeyBiryukov
2 years ago

  • Component changed from General to I18N
  • Keywords reporter-feedback added

Hi @dragy, welcome to WordPress Trac! Thanks for the report.

I can't reproduce the issue on a localized install, both the "Briefly unavailable" message and the login form are displayed in Russian for me, as expected.

Does it still happen with all plugins disabled and a default theme (Twenty Seventeen) activated? Which locale are you using?

#3 @audrasjb
2 years ago

Ok, sorry for my comment, this is definitely working as expected… if you downloaded WordPress in your locale of course :)

Example with fr_FR locale:
https://jeanbaptisteaudras.com/bordel/wp-maintenance.png

Last edited 2 years ago by audrasjb (previous) (diff)

#4 @dragy
2 years ago

Ok, login's english is from "All In One WP Security" plugin. How can I debug maintenance text more? Can via some URL show it for testing?

thanks

#5 @audrasjb
2 years ago

Hi,

This plugin is not translated in every locales so that's probably why you get english strings by default. Note that it can not be your only untranslated plugin.

You can move to translate.wordpress.org and then start to translate it's strings in you locale.
You should also start by learning more about the translation at https://make.wordpress.org/polyglots/

Anyway, I had made a false diagnosis at glance: it is not the fault of WordPress core :)

#6 @dragy
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#7 @netweb
2 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

#8 follow-up: @dragy
2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

actually I see this message in english even on clean installation of wordpress, who can look at this with me on slack?

thanks

#9 in reply to: ↑ 8 @SergeyBiryukov
2 years ago

  • Milestone set to Awaiting Review

Replying to dragy:

actually I see this message in english even on clean installation of wordpress

Which locale are you using?

#10 @dragy
2 years ago

Sergey is gone, anyone else ?

Last edited 2 years ago by dragy (previous) (diff)

#11 @dragy
2 years ago

seriously, anyone else who can look at his with me on slack?

thx

#12 @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

I was able to reproduce the issue by using an English package and choosing Slovak during install, rather than the Slovak package from sk.wordpress.org.

It's the same issue as in #30049: wp_load_translations_early() does not work if neither WPLANG nor $wp_local_package are defined.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.