WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#41940 closed defect (bug) (wontfix)

Problems with the visual editor in Wordpress 4.8.*

Reported by: pascaltraumueller Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: TinyMCE Keywords:
Focuses: ui, administration Cc:

Description

Hello everyone,

I've recently upgrade my wordpress version from version 4.7.5 to 4.8. After this upgrade every user of my website who is using Internet Explorer 11(which is our companies default browser) isn't able to open the visual editor tab in the backend anymore. We don't even have the option to select the visual editor like you can see in this screenshot of the backend editor:https://imgur.com/xUkkQ0G.
This problem also occures after I've disabled all plugins and selected the standard theme, it even appears when I'm using a fresh wordpress installation.
I've tried the following Versions: 4.8, 4.8.1, 4.8.2, but all this version have this problem. When I downgrade to Version 4.7.6 or below there is no problem with the editor. When we use Firefox or Chrome we can select the Visual Editor without any problems.

The Website is running on an IIS Webserver (Version 8.5.9600.16384). The Operating System on this Server is Windows Server 2012 R2.

If you have any questions, feel free to ask.
Kind regards,

Pascal

Attachments (1)

ie11.png (28.3 KB) - added by azaozz 4 years ago.

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
4 years ago

  • Component changed from Posts, Post Types to TinyMCE

#2 @SergeyBiryukov
4 years ago

Hi @pascaltraumueller, welcome to WordPress Trac!

Does the issue still happen with all plugins disabled and a default theme (Twenty Seventeen) activated?

#3 @pascaltraumueller
4 years ago

Hello @SergeyBiryukov, thanks!

Like I've written above this problem also occures after I've disabled all plugins and selected the standard theme, it even appears when I'm using a fresh wordpress installation.

@azaozz
4 years ago

#4 @azaozz
4 years ago

  • Keywords reporter-feedback added

IE11 is working properly here. Any chance that you have IE extensions that may be causing this?

Next step is to open the browser tools (F12), switch to the console, then force-reload the page and paste here all JS errors that you see. This should provide some clues to what's going on.

#5 @pascaltraumueller
4 years ago

@azaozz Thanks for the answer.

The first thing I've noticed that you are using a different Internet Explorer Version. We are using Version 11.1593.14393.0.

Because my browser is in german I can only send you the logs in German. If you could say me how I can change the language there I'd send them to you again. These are the logs im getting:

HTML1402: In der Zeichenreferenz fehlt ein Endsemikolon ";".
post-new.php (992,49)

One thing to notice: This site is an intern site so the website is opened in Compatibility Mode by default.
If I disable the compatibility mode or change the user-agent to MS-Edge the editor works finde. Sadly both of these options aren't real options for us.

#6 @azaozz
4 years ago

the website is opened in Compatibility Mode by default.

This is probably the cause. TinyMCE expects to run in IE11, it doesn't support older versions any longer. Think there is a way to set which sites (or web pages) to be in compatibility mode, perhaps try using that to turn it off on the Edit Post screen.

Last edited 4 years ago by azaozz (previous) (diff)

#7 @pascaltraumueller
4 years ago

I know the way to add a site to the Compatibility Mode but I don't know a way to remove an intranet site from this list.
Do you know how I can turn it off for a specific site? If possible without any 3rd Party-Programm.
Or is there any way to get it running?

#8 @azaozz
4 years ago

Do you know how I can turn it off for a specific site?

I'm afraid no. It's been many years since I've looked at IE in details. Another option may be to use something like IE Tab? Yet another option is to use <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10"/> (or similar)to control the mode from the actual pages that need it.

Last edited 4 years ago by azaozz (previous) (diff)

#9 @pascaltraumueller
4 years ago

Unfortionally this is no option for us because the IE is our default browser.

#10 @Clorith
4 years ago

Intranet sites are shown in compatibility mode by default, you can turn this off vi Settings (cogwheel) > Compatibility View Settings, it should be a checkbox, but as you have an intranet, I suspect you are also governed by a Domain Controller, and whoever administrates your network may have to flip the switch for you in that case.

It's not possible to exclude sites form compatibility mode in IE, only add them (personally I recommend disabling any automated modes IE offers and add sites as needed instead).

#11 @johnbillion
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing as TinyMCE in WordPress 4.8+ requires IE11+. The compatibility mode problem is an issue that needs to be resolved by the domain controller.

Refs:

Note: See TracTickets for help on using tickets.