WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#41954 closed defect (bug) (invalid)

Update stuck if timeout from downloads.wordpress.org

Reported by: windyjonas Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

It seems like the core_updater.lock option isn't removed if we get a timeout from downloads.wordpress.org.

$ wp core update
Updating to version 4.8.2 (en_US)...
Laddar ner uppdatering från https://downloads.wordpress.org/release/wordpress-4.8.2-no-content.zip...
Warning: cURL error 28: Connection timed out after 10000 milliseconds
Error: cURL error 28: Connection timed out after 10000 milliseconds
$ wp core update
Updating to version 4.8.2 (en_US)...
Error: En annan uppdatering körs för närvarande.
$ wp option delete core_updater.lock

(The error message is in Swedish and says: Error: Another update is currently in progress )

Change History (2)

#1 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Type changed from enhancement to defect (bug)

Hey @windyjonas and welcome to Trac,

Looking at the WordPress core code, the lock is correctly released there.

It appears that WP-CLI overrides the core download functionalities which I suspect is where the issue is coming from.

It looks like this issue is even documented: https://github.com/wp-cli/core-command/blob/master/src/Core_Command.php#L876-L878

This should be reported to the WP-CLI Github account directly: https://github.com/wp-cli/core-command/issues

I'm marking this as invalid as it's not the core WordPress code in question

This ticket was mentioned in Slack in #cli by dd32. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.