WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#42178 closed enhancement (invalid)

Outdate-notice for Firefox ESR on dashboard

Reported by: wemhoff Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Hi,

the Wordpress dashboards warns a user for an old Firefox Version, even if the user has an ESR Version. But many companies are using the Firefox ESR Version.
So, it's not fully correct, that the Firefox is outdated.

The problem is, that many non-technical people are " frightened" about that message.

I suggest three possibilities

  1. On the ESR Version the message did not appear.
  2. There is a new configuration option to disable the message for the whole wordpress
  3. The message is changed to something like: "You don't have the newest Firefox, but a safe one. You only dont' have the newest sh" ;)

Best regards!

Change History (8)

#2 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.8.2 deleted

Hello @wemhoff, welcome to WordPress Trac!

Thanks for the report. This is a known issue and caused by a change to the Browse Happy API, see https://meta.trac.wordpress.org/changeset/5976.

To quote @clorith from Slack:

Unfortunately, there's no way to distinguish ESR from mainstream releases of FireFox
So we either have to artificially lower the FireFox version, or stick with knowing that ESR users will get the notification until firefox introduced a new UA string (there's a 2 year old ticket for that enhancement with no traction, so I wouldn't hold my breath, but that's basically the problem here)

I'm going to close this as invalid since the dashboard widget relies on the Browse Happy API. Any issues related to the API should be reported on https://meta.trac.wordpress.org/.

#3 @SergeyBiryukov
4 years ago

  • Component changed from General to Administration

#4 follow-up: @wemhoff
4 years ago

Ok, I understand. But what's with the possibillity to disable the whole message? Or with my third suggestion?

This ticket was mentioned in Slack in #core by afercia. View the logs.


4 years ago

#6 in reply to: ↑ 4 ; follow-up: @SergeyBiryukov
4 years ago

Replying to wemhoff:

Ok, I understand. But what's with the possibillity to disable the whole message?

There's a plugin for that in #27626: ticket:27626:disable-wp-check-browser-version.0.2.php.

#7 in reply to: ↑ 6 @wemhoff
4 years ago

Replying to SergeyBiryukov:

Replying to wemhoff:

Ok, I understand. But what's with the possibillity to disable the whole message?

There's a plugin for that in #27626: ticket:27626:disable-wp-check-browser-version.0.2.php.

Yeah, nice solutions: The Coreplugin works not properly. Install a new one to disable it ... sorry ...
Why is this https://core.trac.wordpress.org/attachment/ticket/27626/disable-wp-check-browser-version.0.2.php not per default part of the core?

#8 @SergeyBiryukov
4 years ago

#43475 was marked as a duplicate.

Note: See TracTickets for help on using tickets.