WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 22 months ago

Last modified 20 months ago

#42479 closed enhancement (duplicate)

Parse location data from video and audio uploads

Reported by: desrosj Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: needs-patch needs-unit-tests
Focuses: Cc:

Description

Latitude and longitude GPS data should be parsed from video and audio uploads and stored in meta whenever possible. This could open up lots of potential for interesting use cases.

#9257 is handling images.

Change History (6)

#1 @desrosj
23 months ago

  • Type changed from defect (bug) to enhancement

#2 follow-up: @melchoyce
23 months ago

Could this data be used for malicious purposes? Is there any way to limit how public this data is by default?

#3 in reply to: ↑ 2 @dd32
23 months ago

Replying to melchoyce:

Could this data be used for malicious purposes? Is there any way to limit how public this data is by default?

Given we don't strip the data from uploads itself, it'd be merely making the data more accessible to WordPress plugins & themes.
I would assume we'd store it in an underscored field _location_data maybe? which would mean that unless a plugin/theme chose to expose it, it shouldn't be queryable in any way.

Note: Images in #9257 is probably a better place to discuss the implications of this, leaving this purely for extending anything done for images to audio/video

Last edited 23 months ago by dd32 (previous) (diff)

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


23 months ago

#5 @wonderboymusic
22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9257.

The image ticket is sufficient - the only location data available in audio/video is in the associated image (if supplied), if it contains "Recording Location"

http://id3.org/id3v2.3.0

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


20 months ago

Note: See TracTickets for help on using tickets.