WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#42815 closed defect (bug) (invalid)

Console js error while loading Customizer(Uncaught TypeError: Cannot read property 'action' of null)

Reported by: coderarjun Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: Cc:

Description

This form is for reporting bugs in WordPress 4.9.1

Note:

  • This error is found in WordPress Customizer Version 4.9.1, it's an error due to WP 4.9.1, not on themes.

Thank You

Change History (8)

#1 @adamsilverstein
22 months ago

Hello @coderarjun - thanks for your bug report and welcome to WordPress trac!

I tried to reproduce this locally and do not see the errors you mentioned. Do you get the errors right away on load?

Can you please try accessing the customizer again with all plugins disabled and a default theme active? Also, please do a 'hard refresh' (shift + reload) to ensure you get fresh JavaScript -sometimes these files can get cached by your browser and do odd things.

Thanks.

https://cl.ly/3c0y3X1O3e2t/Customize_WordPress_Local_Development__Yes_Another_WordPress_site_2017-12-06_08-51-10.jpg

#2 @adamsilverstein
22 months ago

  • Keywords reporter-feedback added

#3 @westonruter
22 months ago

  • Component changed from Administration to Customize

#4 @garrett-eclipse
22 months ago

I noticed this throughout my wp-admin as well. After troubleshooting I determined it was caused by the Grammarly Chrome extension and would assume you're experiencing something similar. This is a new issue with 4.9. Let me know if this should be opened with Grammarly instead.
Thanks

#5 @dingo_bastard
21 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I can confirm as well that this is the Grammarly issue. If you expand the error in the console, you'll see that Grammarly is causing this.

I'll report this to Grammarly.

#6 @garrett-eclipse
21 months ago

Thanks @dingo_bastard that reminds me I opened with Grammarly previously as well and they're aware of the issue, comment from their support;

Please rest assured that the technical team is aware of the problem and they are currently working on it.

Unfortunately, this will not be a quick fix and I cannot provide you with an estimated timeframe, as the developers will need some time to analyze the cause of this issue.

Iā€™m going to close this case, but if you have further information regarding this issue, please reply to this email and the case will be re-opened for further investigation. We apologize for any inconvenience caused.

#7 @dingo_bastard
21 months ago

Haha I've just gotten the same mail... Seems like a template answer sadly. We'll see if they publish a fix for the extension.

#8 @afercia
21 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Version 4.9.1 deleted

See follow up in #43005. Seems this is not specifically related to Grammarly but can happen with any plugin passing an empty message to postMessage() which then gets parsed with $.parseJSON().

You can reproduces this at any time just pasting this in your console (use your site url):
postMessage( '', 'http://src.wordpress-develop.test/' )

Note: See TracTickets for help on using tickets.