WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#4301 closed defect (bug) (invalid)

Upload/browse area doubles thumbnails

Reported by: cricalix Owned by:
Milestone: Priority: low
Severity: minor Version: 2.2
Component: Administration Keywords:
Focuses: Cc:

Description

Originally posted at http://wordpress.org/support/topic/118257

Somewhere in the 2.x series of Wordpress, my file uploads started doubling up - I see double thumbnails for every image I upload (see http://www.cricalix.net/~dhill/wordpress-double-thumbs.jpg). The hyperlinks for each thumbnail are identical.

This looks, to me, to be a problem down in upload-functions.php, in the wp_upload_tab_browse() function. It appears to get double attachment entries for any given post.

Tracing the SQL executed:
SELECT SQL_CALC_FOUND_ROWS posts.* FROM posts LEFT JOIN postmeta ON posts.ID = postmeta.post_id WHERE 1=1 AND (post_type = 'attachment') ORDER BY post_date DESC LIMIT 30, 10

returns double entries for each post, and thus generates a doubled count for the next query that gets executed (the found_rows() query).

If I mod the loop in that function, so that it keeps track of the last ID it saw:

if ( have_posts() ) : while ( have_posts() ) : the_post();
if (get_the_ID() == $last_id) { continue; }
.
.
$last_id = get_the_ID();
endwhile;

the output to the browser is what I expect. However, I can't believe that Wordpress is this borked, so it's got to be something in my setup -- or one of the upgrades didn't update some of the schema properly?

I've only got the Spam Karma plug-in, Lightbox plug-in, post levels and the usual moderation ones enabled - no plug-ins relating to uploads at all.

Change History (1)

comment:1 Nazgul6 years ago

  • Milestone 2.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Unable to reproduce this and no traction in almost a year, so closing as invalid.

Feel free to re-open if you have additional information/patches/suggestions/...

Note: See TracTickets for help on using tickets.