WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#43034 closed defect (bug) (invalid)

Multiple times page is added in menu without warning

Reported by: nilamacharya Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.1
Component: Menus Keywords:
Focuses: Cc:

Description

Bug: Multiple times page is added in menu without warning

Attachment for steps: https://www.screencast.com/t/jOBHlmVeUTdO

Steps:

  1. Navigate to Appearance->Menus from left rail
  2. Select "Menu with Live preview"
  3. Select Menu and click on 'Add Items"
  4. Sect "Pages" and add some page, User can see that "+" icon is changed to Tickmark sign, page is added in menu
  5. Again click on same menu , multiple time page is added in menu

Concern: It should show message over there that "this page is already added in menu" because as per Ticket #43033 icons are not updated proper so user wil be confuse here and click multiple times

Attachments (1)

multiple menu.png (853.3 KB) - added by nilamacharya 3 years ago.

Download all attachments as: .zip

Change History (7)

#1 @swissspidy
3 years ago

I don‘t think this behavior is necessarily incorrect. A user should be allowed to add a page to the menu multiple times.

The icon is just an indicator to inform them that the page is already part of the menu.

#2 @subrataemfluence
3 years ago

I think it is somewhat useful, specially when the same page is required to be loaded but linked with different navigation labels in the menu system.

#3 @pmwebindiainc
3 years ago

we should close this ticket as I feel that the description is not a bug

This ticket was mentioned in Slack in #core by pkbhatt. View the logs.


3 years ago

#5 @pkbhatt
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

As discussed on slack it is not a bug I am closing this ticket

#6 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.