WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 months ago

Last modified 2 months ago

#43289 closed defect (bug) (worksforme)

Twenty Seventeen: Menu link to front page won't display the page content

Reported by: jacofuego Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.4
Component: Bundled Theme Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Hi,

When I assign any page as a static front page and put the link to this page in the top menu it won't display after clicking. In other words, I have first link on the manu to the same page as the static front page. When you open the website and want to display the content of this page by clicking on the meny link it won't show.

The other links from the menu works ok. It is just any page which I assign as a static front page.

Twenty Seventeen Version: 1.4

www.rehearsalstudio.uk

Change History (5)

#1 follow-up: @jacofuego
3 years ago

Sorry the website address is www.rehearsalstudioexeter.uk

#2 @fouzul
3 years ago

now is it working ? what you did ? please let me know

#3 in reply to: ↑ 1 @fouzul
3 years ago

help me , i also have the same issue

Replying to jacofuego:

Sorry the website address is www.rehearsalstudioexeter.uk

#4 @poena
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi
I am sorry that you both had to wait so long for a reply.

This is the intended behavior when you set a page as the static front page.
When a menu has a link to the page, the link will lead to the front page, where the page you selected will be displayed. The link will not lead to a single page as example.com/page-slug/

To be sure that there are no issues related to displaying the content, I have tested this with Twenty Seventeen version 1.4 and version 2.6 on WordPress version 5.7.1

#5 @SergeyBiryukov
2 months ago

  • Component changed from Themes to Bundled Theme
  • Description modified (diff)
  • Summary changed from Menu link to front page won't display the page content in Twenty Seventeen Version: 1.4 to Twenty Seventeen: Menu link to front page won't display the page content
Note: See TracTickets for help on using tickets.