WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#43550 closed enhancement (duplicate)

Provide anonymization/personal data removal helper functions

Reported by: allendav Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

For example, come up with functions to provide replacement text for things like name and address fields that can be used by plugins when removing personal data. The ideal text will be recognizable by the administration as having been thus removed, e.g. "Anonymized User".

Since email addresses are at the core of our export and removal strategy, the anonymized email address function should also probably support a random hash or some such, e.g. anonymized-user-123456abcdef@… to avoid creating a situation where all anonymized content ends up pointing at a single fictitious user.

From the ticket scrub discussion in Making WordPress gdpr-compliance chat today.

Change History (3)

#1 @allendav
13 months ago

  • Keywords gdpr needs-patch added

#2 @allendav
13 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #43545.

#3 @ocean90
13 months ago

  • Keywords gdpr needs-patch removed
  • Milestone Awaiting Review deleted
  • Version trunk deleted
Note: See TracTickets for help on using tickets.